如果您喜歡這裡的內容,記得分享到您的Facebook和Twitter上面所有的朋友們吧!

2009年12月31日 星期四

IOS 中 OSPF 的 "network area" 命令, Wildcard Mask 其實可以是 Subnet Mask

 router ospf 1
 network 192.168.1.0 0.0.0.255 area 0 
IOS 中 OSPF 的 "network area" 命令, Wildcard Mask 的欄位其實可以改使用 Subnet Mask 來輸入. 雖然我還沒有找到官方的文件說明, 不過我試了幾個 IOS 的版本/平台都是如此. (感謝 Danny 的發現!)

2009年12月21日 星期一

PowerPoint 2003 的雲 (Cloud) 在哪裡?

我們在製作網路架構圖的時候, 經常會將複雜的網路連線區塊, 直接使用一朵雲的圖片來代表.

(誰說 雲端運算 Cloud Computing 最近才有的呢!)

剛好有朋友問到如何在 Microsoft PowerPoint 中畫一個這樣的雲. 其實 PowerPoint 2003 內建就有一個雲的圖案, 插入就可以用了! 怕有網友漏掉了, 趕快跟大家分享!

2009年12月4日 星期五

Google Public DNS Resolvers: 超好記的 DNS Server: 8.8.8.8 and 8.8.4.4

 Primary DNS: 8.8.8.8 
 Secondary DNS: 8.8.4.4 
應該看一眼就記起來了吧: "8.8.8.8""8.8.4.4"!

這是 Google 所免費提供的: Google's public DNS resolvers.

2009年11月22日 星期日

2009年11月2日 星期一

Windows 7 上沒有 "超級終端機" HyperTerminal 要如何初始設定 Router? 試試 Putty

  Bits per sec  :  9600  
  Data bits     :     8 
  Parity        :  none 
  Stop bits     :     1 
  Flow control  :  none 
我們以往在作Router/Switch 的初始設定, 都會使用 Windows XP 內建的終端機模擬軟體: "超級終端機" HyperTerminal. 但不巧的是, Windows Vista 之後的版本, 包括 Windows 7, 就沒有內建這個軟體了. 要如何解決這個問題呢?

其實我們日常作 SSH 連線時必備的 Putty, 就可以提供經由 PC 的序列 COM 埠對 Router/Switch 的 Console 作初始設定的功能.

2009年10月22日 星期四

ISR G2, Cisco 新版的 Integrated Service Router

Cisco 推出新版的 ISR (Integrated Service Router): ISR G2.

Cisco 將在 2009/10/29 (星期四) 為此舉辦免費的線上活動. 活動內容大綱大致如下:

2009年10月20日 星期二

CCNA考試, 非英語系國家會增加 30 分鐘的作答時間

       非英語系國家

  增加 30 分鐘的作答時間  
CCNA考試, 非英語系國家會增加 30 分鐘的作答時間. 事實上, 所有 Cisco 筆試的考試也都一樣, 非英語系國家增加 30 分鐘.

我課堂中有提過, 給其他朋友參考.

2009年10月19日 星期一

IOS 中 SNMP v1 啟動命令

用這兩行個命令啟動 SNMP version 1 即可:

snmp-server community COMMUNITYNAME RO 99
access-list 99 permit host 168.95.1.1

2009年10月15日 星期四

"寬頻上網" 是 "芬蘭" 法律保障的基本人權

明年 (2010年) 七月起, "1 Mbps 寬頻上網" 就是 "芬蘭" 法律所保障的基本人權之ㄧ了!

我認為, 台灣也應該要立即跟進才對!

這即將成為世界趨勢. 不只是 "芬蘭", Wiki 上還提到, "法國", "愛沙尼亞", "希臘" 等國家也都有類似的法律保障. 不過, "芬蘭" 的法律最明確, 規定是 "1Mbps". 未來 "芬蘭" 甚至還計劃在 2015 年的時候, 將規定的 "1 Mbps" 提升到 "100 Mbps".

2009年10月8日 星期四

IPSec Transform Set "封包保護套餐" 設定說明, 延伸自 "Site-to-site IPSec VPN 設定範例"

本文延伸自前篇文章, "Site-to-site IPSec VPN 設定範例".

請注意: 本範例使用Packet Tracer 5.2版. 如果您要自己建立 .PKT 檔案來驗證 IPSec 的話, Router 請選擇 Cisco 1841 和 Cisco 2811. 其他型號的 "虛擬 Router", 很奇怪地, Packet Tracer 5.2 不支援 IPSec 功能.

2009年10月4日 星期日

Cisco IOS 的下一版是 15.0 版

Cisco IOS下一個版本已經出來了! 有趣的是, 相對於目前大家熟悉的版本 12.4, 下一個版本既不是 13.0, 也不是 14.0, 而是直接跳到 15.0!

2009年10月3日 星期六

感謝 "合勤科技" Zyxel 的客服專員

我將一台家裡汰換下來的 "合勤科技" 很舊的無線路由器 "ZyXEL P-334WT" (大約是2005年的產品) 送給友人, 讓他在家裡也可以使用無線區域網路(Wireless LAN)上網. 由於他的專業並不是在網路上, 所以當他使用上有問題時, 我也只能請他帶過來, 碰面時我再幫他做設定.

2009年9月27日 星期日

如何在 VUE 網站報名 CCNA 考試? 可參考 "恆逸資訊" 網站所提供資訊 (Thank you, Jeremy!)

每次 CCNA 課程結束前, 都需要跟朋友們介紹如何透過 VUE 網站線上報名 Cisco 考試. 總希望有些畫面擷取的步驟說明文件, 好讓大家回去後都還可以隨時參考.

2009年9月25日 星期五

Cisco IOS 流量產生器

 R1#telnet 1.1.1.1 19
 Trying 1.1.1.1, 19 ... Open 
 !"#$%&'()*+,-./0123456789:
要確認網路的穩定性, 通常還是得灌入一些流量, 讓網路承載試看看. 但是如果一時找不到適當的 Client/Server, 來幫我們持續地產生流量, 有沒有別的辦法?

2009年9月15日 星期二

Cisco 建議的 TFTP Server 軟體

TFTP Server 是我們平常在維護網路必備的工具之一. 我們需要 TFTP Server 來備份/安裝 IOS 映像檔, 與設定內容.

Cisco 原本曾經有過一個免費的 TFTP Server 軟體, 不過已經停止它的後續的開發和維護. 反而在 Cisco 網站當中, 建議大家改使用其他 Open Source 的免費軟體.

2009年9月12日 星期六

二進位與十進位間, 數字轉換練習

 153 =  1    0    0    1    1    0    0    1 
       ---  ---  ---  ---  ---  ---  ---  ---  
       128   64   32   16   8    4    2    1 

       2^7  2^6  2^5  2^4  2^3  2^2  2^1  2^0 
每次講到 IP 位址書寫, 都會需要補充 "二進位與十進位間數字互轉" 的解說. 我一直希望手邊有一個環境, 可以提供給大家作自我練習使用.

2009年9月9日 星期三

事前演練的重要性 - 從 "聽障奧運會開幕" 失火意外談起

所有的系統不論大小, 在正式上線使用之前, 整個使用者操作的過程, 一定要完整地演練過一次. 不然, 就好像拿自己的 "職業生涯" 跟 "意外" 在玩一把 "show hand" 一樣: 不是全贏, 就是全輸.

2009年9月7日 星期一

2009年8月30日 星期日

CCNA Exploration 4.0, Packet Tracer 補充練習文章, 鏈結集合收錄在本篇

之前一直忘了將所有 "CCNA Exploration 4.0, Packet Tracer 補充練習" 鏈結集中收錄在同一篇文章中, 現在趕快補上!

想要一次瀏覽三個學期各篇練習的朋友, 請直接將本篇文章加入書籤即可. 歡迎大家多加利用!

2009年8月23日 星期日

CCIE Lab 考試可以放心使用 "show run" 命令

 Router#show run 
 Building configuration... 
早期我們考 CCIE Lab 的時候, Router 都是以 Cisco 2600/3600 系列的 Router 為主. 因為它們的 CPU 真的很慢, 每下一次 "show run", 光是第一個畫面顯示出來, 就要花去大約10秒或甚至更久的時間. 考試當中如果老是要下 "show run" 命令才能弄清楚剛才下過的命令的話, 時間肯定是不夠用.

當年我們就必須要想一些最佳化的辦法, 其中包括所謂的 "write once, read multiple times" 法: 就是使用 "write" 命令先存檔一次, 再使用 "show start" 的方式仔細分次讀取, 會快很多! (Thank you, Michael!)

另外, 對於路由資訊交換協定, 我們就必須熟用例如 "show ip protocols" 等直接列印狀態的 show 命令, 以減少對於 "show run" 命令的依賴. 所以各位知道為何本 Blog 取名為 "showipprotocols" 了吧!

然而現在的 Lab 考試來說, 至少都是使用 Cisco 3725 以上的 Router, CPU 效能也都不再是問題了, 反而我們應該好好思考, 如何善用 "show run" 命令來加速我們的設定檢查.

常用的三個技巧, 是使用 "|" (pipe, 借用自Unix) 來減少輸出的內容. 其中 "| include" 只顯示含關鍵字的那幾行; "| section" 只顯示段落第一行含關鍵字的那幾個段落; "| begin" 自含關鍵字出現的那行開始印.

以下是一個簡單的示範.

Router#show run | include bgp
router bgp 1
 bgp log-neighbor-changes
Router#show run | section bgp
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0
 neighbor 2.2.2.2 remote-as 2
 no auto-summary
Router#show run | begin bgp
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0
 neighbor 2.2.2.2 remote-as 2
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
 --More--  

這個技巧不單是應付考試, 實務上也很有用!

時間和環境都不一樣了, 考試技巧我也應該跟著改變!

2009年8月17日 星期一

台灣的網站, 如果你的 Internet 使用者都集中在 "荷蘭", 應該放哪一家 ISP 比較好!


(畫面擷取自TWNIC網站)
台灣ISP出國頻寬分布統計Flash動畫
當然這是一個假設性的問題, 我相信並不是所有的網站客戶, 都平均分配在各國. 有沒有一個客觀的資料是可以參考的?

朋友告訴我這個TWNIC的服務, 我覺得很有參考價值. 這個網站正好可以告訴我們, 台灣的各家 ISP 有連接到哪幾個國家, 以及跨國總頻寬分別有多少.

直接點選開啟最新的報告, 然後將滑鼠移到你所關心的國家上, 動畫就會出現有連結的 ISP 的與總頻寬是多少. 一目瞭然!

雖然本頁面的資訊, 看起來是依據各 ISP 回報給 TWNIC 的資料手動繪製, 會有些許的時間差. 我相信對大家還是很有幫助的!

[Reference]
TWNIC網站服務: 台灣ISP出國頻寬分布統計Flash動畫

2009年8月13日 星期四

APCN 和 APCN2 海底電纜有障礙

昨天(Aug 12, 2009)上班時間收到中華電信通知說, APCN 和 APCN2 海底電纜有障礙, 因此 Internet 連接中國到台灣間, 與新加坡到台灣間, 都會變得很慢!

今天又學到四個專業術語: APCN, APCN2, "海底電纜, Submarine communications cable", 和 "海纜接陸點, Cable Landing Point".

Wiki 上有這四個專業術語的解釋:
  1. APCN: Asia-Pacific Cable Network
  2. APCN 2: Asia-Pacific Cable Network 2
  3. 海底電纜, Submarine communications cable
  4. 海纜接陸點, Cable Landing Point

2009年8月9日 星期日

Internet BGP路由資訊數已經達到 30 萬筆 (300,000)

我看到這篇文章:"BGP breaks 300,000". 如果使用我之前的粗略估計(10萬筆約需要70M bytes)來算, 光是存放這些Internet BGP的路由資訊, 就需要 210M bytes.
今天(2009年八月)的 Internet BGP 路由資訊數目, 和2000年初(大約75,000筆)比較起來, 是當年的四倍多.可以算是暴增的數字啊!

[References]

2009年8月3日 星期一

BGP 記憶體需求估計

我找到這個網頁, 可以幫助我們估計所需要的記憶體大小.
這篇文章原本是要介紹 "如何減少記憶體使用量". 然而, Conclusion 段落中的數據例子解答了我的問題:


Number of Prefixes

Memory Consumed

No Filtering

98,410

70,882,248

Autonomous System Filter

31,667

28,132,528

如果本表屬實的話, 那我就可以這樣估計: 10萬筆的 BGP table, 大約需要 70M 的記憶體來儲存.

一位友人以他的所管的 BGP 路由器來看, 確認這個估計蠻準確的. 不知各位的 BGP 路由器是否也適用這個估計算法呢?

[Reference]
"Achieve Optimal Routing and Reduce BGP Memory Consumption" on Cisco.com

2009年7月27日 星期一

IP Helper Address 轉送後的封包, 來源位址應該是什麼?

我做了一個小小的驗證 Lab. 發現 "IP Helper Address 轉送後的封包, 來源位址應該就是啟用 "IP Helper Address" 的那張網卡的IP位址.
R0的畫面擷取說明如下:
  1. 尚未啟動 "Helper" 前, 所有的 DHCP broadcasts (DISCOVERY) 都不被理會.
  2. 啟動 "Helper". 請注意, 啟動的網卡IP位址就是 "2.1.1.10", 轉送的目的地IP位址就是 "1.1.1.1"
  3. 啟動後, Debug訊息顯示, 該 DHCP 封包來源位址從 "0.0.0.0" 改成 "2.1.1.10", 目的地位址從"255.255.255.255" 改成 "1.1.1.1". 然後被送到 DHCP server (R1).
  4. DHCP server 所回應的封包 (OFFER) 來源位址是 "1.1.1.1", 目的地位址是 "2.1.1.10".
  5. 這個封包再被 "Helper" 轉送給 DHCP Client. 同時來源位址再次改成她自己的位址 "2.1.1.10", 目的地改成"255.255.255.255", 猶如這個 DHCP 回應就是她自己所產生的.

R0#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  up                    up      
FastEthernet0/0.200        2.1.1.10        YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial1/0                  1.1.1.10        YES manual up                    up      
Serial1/1                  unassigned      YES manual administratively down down    
Serial1/2                  unassigned      YES unset  administratively down down    
Serial1/3                  unassigned      YES unset  administratively down down    
R0#
*Mar  1 00:42:43.599: IP: s=0.0.0.0 (FastEthernet0/0.200), d=255.255.255.255, len 604, rcvd 2
*Mar  1 00:42:47.111: IP: s=0.0.0.0 (FastEthernet0/0.200), d=255.255.255.255, len 604, rcvd 2
*Mar  1 00:42:51.159: IP: s=0.0.0.0 (FastEthernet0/0.200), d=255.255.255.255, len 604, rcvd 2
R0#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R0(config)#int f0/0.200
R0(config-subif)#ip helper-address 1.1.1.1
R0(config-subif)#end
R0#
*Mar  1 00:43:07.607: %SYS-5-CONFIG_I: Configured from console by console
*Mar  1 00:43:09.239: IP: s=0.0.0.0 (FastEthernet0/0.200), d=255.255.255.255, len 604, rcvd 2
*Mar  1 00:43:09.255: IP: tableid=0, s=2.1.1.10 (local), d=1.1.1.1 (Serial1/0), routed via FIB
*Mar  1 00:43:09.259: IP: s=2.1.1.10 (local), d=1.1.1.1 (Serial1/0), len 604, sending
*Mar  1 00:43:09.439: IP: tableid=0, s=1.1.1.1 (Serial1/0), d=2.1.1.10 (FastEthernet0/0.200), routed via RIB
*Mar  1 00:43:09.443: IP: s=1.1.1.1 (Serial1/0), d=2.1.1.10, len 328, rcvd 4
*Mar  1 00:43:09.459: IP: s=2.1.1.10 (local), d=255.255.255.255 (FastEthernet0/0.200), len 328, sending broad/multicast
*Mar  1 00:43:09.567: IP: s=0.0.0.0 (FastEthernet0/0.200), d=255.255.255.255, len 604, rcvd 2
*Mar  1 00:43:09.583: IP: tableid=0, s=2.1.1.10 (local), d=1.1.1.1 (Serial1/0), routed via FIB
*Mar  1 00:43:09.587: IP: s=2.1.1.10 (local), d=1.1.1.1 (Serial1/0), len 604, sending
*Mar  1 00:43:09.619: IP: tableid=0, s=1.1.1.1 (Serial1/0), d=2.1.1.10 (FastEthernet0/0.200), routed via RIB
*Mar  1 00:43:09.623: IP: s=1.1.1.1 (Serial1/0), d=2.1.1.10, len 328, rcvd 4
*Mar  1 00:43:09.635: IP: s=2.1.1.10 (local), d=255.255.255.255 (FastEthernet0/0.200), len 328, sending broad/multicast
R0#
R0#

所以, 這本書有關 "ip helper address" 的描述是錯誤的: Wendell Odom, Rus Healy, Naren Mehta."CCIE Routing and Switching Exam Certification Guide, 3rd Edition", Page 128 和 Page 134!

2009年7月24日 星期五

準備 CCIE 認證

最近因為工作的關係, 知道有三位友人正在準備 CCIE Routing and Switching 的認證. 有興趣一起準備的朋友, 歡迎來信讓我知道!


2009年7月19日 星期日

原來 VTP 的 Password 是可以看到的!

我一直沒有注意到, 原來 VTP (VLAN Trunking Protocol) 的 Password 是可以使用 "show" 命令看到的!

這兩天經過同學的提醒我才注意到. 命令就是 "show vtp password". 詳情可參考這篇 "Configuring VTP Global Parameters".

Switch#show vtp password
VTP Password:WATER
Switch#

我真是不夠細心! 這應該在 ICND 就要會的!

2009年7月13日 星期一

VTP介紹動畫, Cisco官方網站上看到的

在找資料時碰巧看到這個介紹VLAN Trunking Protocol (VTP) 的 Flash 動畫. 官方 Cisco.com 上面的喔! 我認為介紹得很清楚而且非常深入. 應該對各位會很有幫助!

http://www.cisco.com/warp/public/473/vtp_flash/

雖然是英語發音版的, 我相信也難不倒大家!

2009年7月8日 星期三

VLAN 文件化圖示的方法討論

VLAN 日常維護的工作重點之一, 就在於如何簡單地製作成文件化圖示, 讓其他人一目了然. 我過去都是使用 "橢圓形" 來代表各個不同的 VLAN. 這個方法有缺點, 就是當 VLAN 數目多的時候, 顏色很快會不夠使用. 而且每個 VLAN 所佔的空間比較不好調配.


今天看到這篇文章, 我認為他的方法比我的要好得多!

他的方式簡單的講, 就是使用水平粗線, 代表 VLAN 和子網段. 然後網路設備就使用垂直線接上該水平線, 代表與該 VLAN 子網段相接. 有點像音樂的 "五線譜" 一樣.

這樣一來最大的好處, 就是可以在單張的圖片中容納更多的 VLAN 數. 同時也比較不會有顏色用完的問題, 因為網段位址和 VLAN 號碼直接標上, 顏色甚至可以重複使用!

在此也想問問網友, 你認為呢? 或者你有更好的方法, 可以跟大家來分享的? 歡迎大家直接使用本文章下方的 "張貼意見"來提出你的看法!


Reference:

2009年6月30日 星期二

更高一層的認證挑戰: Cisco Certified Architect

今天一早看到這篇新聞稿: Cisco 宣佈新的高於 CCIE/CCDE 的更頂級認證: Cisco Certified Architect:
Cisco Raises the Bar with Highest-Level IT Networking Certification: Cisco Certified Architect

New Certification Resides Above CCIE to Validate Competency and Experience in Support of Growing Innovation in Network Infrastructure Architecture

SAN JOSE, Calif., June 29, 2009 – Responding to strong customer and market demand to recognize the architectural expertise of network designers, Cisco today introduced the Cisco Certified Architect, the highest level of accreditation achievable within Cisco® Career Certifications.

有多難考呢?
  1. 通過CCDE, 並有大約10年的網路業工作經驗. 最後要申請審查, 通過後才有資格參加 Cisco Certified Architect 的認證考試
  2. 網路上看到的文章顯示, 考試過程大致跟 "川普" 的電視節目 "誰是接班人 (The Apprentice)" 節目很像, 要書面應答和口頭答詢.
如果有朋友想要準備這項認證的, 請記得讓我知道, 來為你加油一下!

2009年6月26日 星期五

如何遠端列出 Cisco 硬體和各模組的序號

工作實務上常常會需要, 透過遠端連線, 查找安裝在各地點的 Cisco Router/Switch 硬體和上面模組的序號.

有哪些命令可以幫助我們來列出呢? 因為 Cisco 硬體的產品線太多了, Router 或是 Switch 的命令都不太一樣, 要仔細按產品來一一說明, 還真不容易.

我看到這篇文章, 作者 Calin 使用 Cisco Catalyst 6500 switch 來舉例. 一般來說, Cisco Catalyst 6500 是非電信業者用戶, 所會使用到功能組合最複雜的 Router/Switch 硬體, 所以很有代表性. 我將他列舉出來的五個 show 命令, 再補上 Router 的 "show diag" 命令合在一起, 調整一下順序, 方便大家來剪貼使用.


! Copy Begin
term len 0
show version
show diag
show inventory
show module
show diagbus
show idprom all

! Copy End


至於輸出的內容, 各位可以參考原作者網頁, 最好是自己親自試試看, 應該很快就可以看到 "序號" 在哪裡!

雖然還有一個命令 "show tech-support" (或是縮寫成 "show tech" 即可), 可以達到相同功能, 但是我必須強調不建議使用! 因為這個命令會瞬間損耗太多設備上的 CPU 時間, 而且停不下來! 尤其在線上運作的設備執行, 很有可能會立刻影響網路效能. 這個 "show tech" 命令只適合 "離線" 使用!

[Reference]

2009年6月17日 星期三

三種 Spanning Tree 協定的 IEEE 編號速記法

Spanning Tree 的三種協定分別定義在 IEEE 802.1(?) 等文件中, 其中(?)可能是 "d", "w", "s" 三個英文字母其中之一, 分別有不同的意義. 我個人認為如果只考各位背誦這幾個文件編號的考題, 實在很無趣. 偏偏類似 BCMSN 的考試又常出現這類考題. 所以在準備考試的時候, 我們還是得硬背起來.

我看到這篇文章提供了一個簡單的速記法, 應該可以解決大家的困擾:
  1. 802.1d(”Classic” Spanning Tree) – It’s dog-gone slow
  2. 802.1w(Rapid Spanning Tree) – Imagine Elmer Fudd saying ‘rapid’ as “wapid”
  3. 802.1s(Multiple Spanning Tree) – You add the letter ‘s‘ to nouns to make them plural(multiple)

有沒有茅塞頓開的感覺!

其中 (1) "該X地慢", 和 (3) "英文的複數要加 S" 應該一看就懂. (2) 就要想像一下了. "Elmer Fudd" 其實就是古早古早的華納兄弟的卡通影片中, 每次要抓"Bunny 兔" 和 "Graffy 鴨" 都會失敗的那位獵人. 他講話會有點漏風漏風的, "rabbit" 他說起來很像 "wabbit". 我找到 Youtube 上 Elmer Fudd 的這段影片. 請直接快轉到第 49 秒, 各位就會有非常深刻的印象!



各位是否都記住了呢!


[Reference]
"Memory Tricks To Remember IEEE STP Designations", by "CCIE Pursuit Blog"

2009年6月16日 星期二

Cisco 變成 "道瓊工業指數" 所參照的第五家科技公司

剛才注意到一則的新聞: 自2009年6月8日起, "Cisco" 和 "Travellers" 正式取代剛宣布破產保護的"通用汽車" (General Motors, GM) 和重整中的花旗集團 (Citigroup), 成為道瓊工業指數 (the Dow Jones Industrial Average) 的參照成員之一.

查了一下 Wiki, 才知道道瓊工業指數所參照的成員一共只有 30 家. 其中科技公司還有另外四家: HP, Intel, IBM, 和 Microsoft.

這對 Cisco 公司是一個很重大的肯定! 對於準備考 Cisco 證照的朋友來說, 我相信也有更多的激勵才是!

[Reference]

2009年6月2日 星期二

"你的時間在哪裡,你的成就就在那裡"

各位看到我這篇文章, 表示你正在上網找資料學習. 這樣很好! 可是其他的時間呢?

我們常聽到這句勉勵的話: "你的時間在哪裡,你的成就就在那裡". 各位不妨也自我檢查一下, 你的時間都花在哪裡呢?

我每天要花近兩個小時通車上下班. 我的習慣是帶本書在車上讀. 我每天幫自己賺了快兩小時的時間來學習. 不少同車的人, 和我不同, 是拿著捷運上 "施捨" 來的免費報紙. 他們也相同地每天讀了近兩小時, 只不過讀的是贊助商的廣告和低級趣味. 各位覺得你的時間應該如何運用比較好?

我上網花最多的時間, 是在 Google Reader [如何使用介紹]上. 每天看到的內容, 都是我自己所訂閱的. 畫面中有如此多的資訊, 讀不完, 真希望我可以有好幾倍的時間來消化他們. 我看到很多人, 瀏覽器的首頁設定是某家入口網站的首頁. 一打開, 滿滿的都是別人設定好的內容, 接下來通常就會隨著幾個辛辣和暗示性的標題, 在裡面來回穿梭. 各位覺得你的時間應該如何運用比較好?

我家的電視機, 是讓我拿來上網和看我需要的影片用的. 有線電視, 我老早就不租用. 真的也是沒有時間看, 何必浪費一個月約 600元 的新台幣在上面? 這些省下來的錢夠我每年租兩家 Web Hosting 服務. 各位是否統計過, 你每天花多少時間在別人指定好內容的電視頻道中?

"勿以善小而不為, 勿以惡小而為之", 各位是否也應該開始採取行動了呢?

2009年5月31日 星期日

Cisco IP 話機網路線接法, 看照片比較清楚

Underside of a Cisco 7941 IP Phone
Underside of a Cisco 7941 IP Phone,
originally uploaded by Dan_H.
我在Flickr.com上面找到這一個比較清楚的圖. (右方, 點入放大).

最左方的 AUX 有其他功能我們先不看. 畫面中間左方網路孔 "10/100/1000 SW" 孔位是讓我們上鏈 (Uplink) 到交換器, 最右方網路孔 "10/100/1000 PC" 是讓我們接到座位的PC.

所以簡單地說, 典型的 Cisco IP 話機本身就包含一個兩埠的小交換器. 其中上鏈孔還必須以 Trunk 模式啟動, 因為同時要承載電話本身的封包(Voice VLAN), 和座位 PC 的流量 (沒有加標籤的原生VLAN, Native or Untagged VLAN).

2009年5月26日 星期二

為何 IP Multicast 位址的 MAC address 必須擠到23 位元裡面 ?

應該各位在讀到 BSCI 教材中, 有關 IP Multicast 位址要對應到適當的 MAC address 來傳送這段時, 都會注意到: 好麻煩喔, 為什麼要設計成這樣, 硬是將數目比較多的 IP Multicast 位址, 以 "32比1" 的方式, 擠到比較小的 MAC Address 範圍內? 而且還是僅保留低位元的 "後23位元" 這麼奇怪怪的數字, 害我們這麼辛苦, 要去記對照規則!

其實這是有一段小故事的!

據說當年 IP Multicast 之父 Steve Deering 在還是研究生的時候, 為了要實作 IP Multicast 的驗證雛型, 必然也需要專用的 MAC 位址來給 IP Multicast 封包, 在 LAN 上面傳輸時使用.

各位應該知道, IP Multicast 的位址範圍, 是在 224.0.0.0 ~ 239.255.255.255 間的 D 等級網段. 如果要讓每一個IP Multicast 位址都有專有的 MAC 位址, 一共需要 2^28 個 MAC 位址, 也就是, 需要 16 個 OUI 的範圍才夠.

我們從二進位來看, 就會比較清楚:


    33          2          1          0
    1098765.43210987.65432109.876543210
    -------------------------------------

    (  224  .   0    .   0    .   0   )
    11100000.00000000.00000000.00000000

    11101111.11111111.11111111.11111111
    (  239  .  255   .  255   .  255  )

各位應該還記得我前一篇有關 MAC 位址的費用, 現在每一個 OUI 要 US$ 1,650, 當年要價也要 US$ 1,000. 換句話說, Steve 當年需要想辦法來支付 US$ 16,000 (相當於新台幣50多萬元) 給 IEEE, 才夠他完全的一對一來分配唯一的 MAC 位址給每個 IP Multicast 位址專用.

很不幸, 經費沒有那麼多, 只夠他申請一組 OUI, 也就是最多只有 2^24 個 MAC 可以使用. 這組得來不易的 OUI 當然也要省著用, 所以要先保留一個位元不能用, 所以只剩下 23 個位元, 也就是 2^23 個 MAC 位址才可以給 IP Multicast 位址使用.

這個當初 Steve 申請到的 OUI "01-00-5E(註1), 就成了我們今天 IP Multicast 專用的 MAC 位址的 OUI !

所以各位看到訊框的目的地 MAC 位址, 都會長成這個模樣:


                            |<        23 bits      >|
00000001-00000000-01011110-0XXXXXXX-XXXXXXXX-XXXXXXXX
   01   -   00   -   5E   -(00~7F) -(00~FF) - (00~FF)

所以這個故事也讓我們學到一件事: 錢還是很重要的!

[參考資料]


註1: 比較正確一點地說, 應該 Steve 註冊到的 OUI 是 "00-00-5E" 才對. 但是載送 IP Multicast 封包的訊框上第一個 Octet 的 multicast bit 一定是打開的, 所以使用類似 Wireshark 看到的時候外觀都會是 "01-00-5E".

2009年5月22日 星期五

IEEE OUI 和 IAB的註冊費用

Breathless (DSC_0543)
Breathless (DSC_0543),
originally uploaded by Li-Ji.
IAB (Individual Address Block) 簡單的講起來, 相當於是個人或是小團體可以負擔得起的, 除了OUI以外的申請全球唯一的 MAC Address 的方式.

當然價格便宜的話, 可用的位址一定比較少. 沒錯, IAB 你只有 12 位元可以自由使用, 所以一共是 4096 個 MAC Address 可用.

OUI 則有 24 個位元可以自由使用, 所以一共是大約一千六百多萬個位址可用.

如下圖所示, IAB 註冊費是 US$ 550, OUI 是 US$ 1,650. 雖然還是所費不貲, 不過好消息是沒有年費! 所以可以終身使用!

http://standards.ieee.org/faqs/OUI.html#q2

What costs are involved with obtaining an OUI, IAB or EtherType Field?

The OUI is $1,650.00 (US); the IAB is $550.00 (US) and the EtherType Field is $2,500.00 (US). The only other fees that would be involved is a $15.00 bank fee that is only applicable with the wire transfer payment method and a fee for private status on the public listing. There are no annual fees.

從這個圖我們還看到了連訊框中的 16位元的 EtherType 都可以付費買下, 只不過稍微貴了一點: US$ 2,500.

2009年5月21日 星期四

Wireshark 怎麼知道訊框是由哪一廠牌的網卡送出?

關鍵就在於, MAC Address 並不是可以隨便用的, 而是要統一跟 IEEE 申請繳費的. 各位應該都還記得, 48位元的 MAC Address 當中, 從高位元數下來的前 24 位元是所謂的組織唯一識別碼 (Organizationally Unique Identifier, OUI). 這個數值是就是由 IEEE 配發的. 至於剩下的其他 24 位元, 才是由廠商自己分配.

所以, Wireshark 這種 "封包擷取軟體" 裡面其實就是參考了這樣的對照表, 所以一收到訊框, 查完前 24 位元, 馬上就知道是哪家廠牌製造的.

那麼這個對照表要去哪裡下載或是查詢? 其實就在 IEEE 的網站當中.



[Wireshark (就是以前的 Ethereal) 參考資訊]

2009年5月20日 星期三

Wireless LAN 佈建方式補充說明

雖然 "Cisco 網路學院" 的教材裡面, 例子中使用的是 Cisco Linksys 這種個人使用的 Wireless LAN 接入點 (Access Point). 實務上, 如果當你的 Wireless LAN 到了一定的規模, 通常的作法是改用集中式管理 (centralized management) 的, 或 Cisco 所稱呼的輕薄型接入點 (Thin AP) 功能的產品.

這種新的的 AP 架構, 關鍵在於"集中式管理". 我們不再需要一台一台 AP 去維護設定, 僅需要在集中控管的"控制器"(Wireless LAN Controller) 上設定好, 所有的 AP 一開機就自動註冊到控制器, 然後由控制器端完全遙控 AP 的動作.

說遙控可是一點都不誇張, 因為所有 AP 動作都透過 IP 網路聽命於控制器, 這個時候 AP 變成是 "沒有大腦的遠端 Wireless LAN 網路卡", 控制器才是所有功能的核心. 在這樣的架構下, AP 不能單獨運作, 一定要搭配控制器才能動作.

我們可以類比想像, 就好像一個主人(控制器) 同時在放好多風箏 (AP) 一樣. 風箏 (AP) 要飛高飛低是完全受主人(控制器)的大腦在遙控. 在所以 Cisco 稱呼他是輕薄型接入點設計, 就是要強調這一點.

所以這種架構, AP 不能單獨運作, 一定要搭配控制器. 通常為了備援, 控制器都是兩套以上.

至於 "一定的規模" 應該有多大, 就應該改考慮使用新架構? 我個人的建議是 兩台 以上. 要不然, 通常的經驗就都會 "一路錯下去": 因為 Thin AP 價格真的不菲, 是一般 AP 的 10 倍以上的價格! 但是效益要等到開始用(管理), 才發揮得出來!


[參考資料]

http://www.cisco.com/web/about/ac123/ac147/archived_issues/ipj_9-3/wireless_lan_switches.html

2009年5月19日 星期二

使用者端的 Redundancy: Wireless LAN. 備援 Internet 完整版

延續前一篇, 知道解法了嗎?

關鍵也是更精準的路由資訊 (more specific route): 只要比 "預設路由" 還要更精準就可以了! 其實預設路由是 "最不精準的" (least specific), 即使只要多精準一個位元就好, 不就比她還要精準了嗎!

---

公布答案了: 就是再加上 0.0.0.0/1128.0.0.0/1 這兩筆路由, 將它們都指向有線 LAN 網段的閘道器 IP 位址即可! 所以 Internet 的連線也一樣會先走有線的 LAN, 斷線後才走 Wireless LAN!

用十進位不容易看出來, 改用二進位就很清楚:

33          2          1          0       33          2          1          0
1098765.43210987.65432109.876543210       1098765.43210987.65432109.876543210

00000000.00000000.00000000.00000000, mask 10000000.00000000.00000000.00000000

10000000.00000000.00000000.00000000, mask 10000000.00000000.00000000.00000000

當然, 相同的想法, 也可以拆成四個路由, 八個路由等等, 所以答案不只這一組. 但是兩個是最簡單的!

有一點腦筋急轉彎, 不過這招真的很好用!

2009年5月17日 星期日

使用者端的 Redundancy: Wireless LAN

Yellow Flowers (DSCN0947)
Yellow Flowers (DSCN0947),
originally uploaded by Li-Ji.
使用者端使用 Wireless LAN 有一個最不可取代的好處, 是一般的有線的 (Wired) LAN 完全作不到的, 就是全自動復原的功能! Windows 會自動去找下一個可以使用的 Wireless LAN 接入點 (Access Point)! 所以是可以做到讓使用者完全感受不到網路斷線的問題!

不過, Wireless LAN 即便是現有的技術, 還是有著頻寬不足的問題, 尤其是當使用者非常密集地坐在一起, 每一位都需要大量資料傳輸的時候! 如果使用者端只使用 Wireless LAN, 碰上了這種環境, 就會有被抱怨的風險! 這將會是網管人員的惡夢!

所以另外一種做法, 是做將 Wireless LAN 當作有線 LAN 的備援來使用. 這樣倒是可以兩者兼顧, 平常都使用有線的 LAN 網路傳資料, Switch 故障時再讓使用者端使用 Wireless LAN 上網, 當然故障的時候網路還是會慢一點, 但是至少不會全斷!

可是能做到自動切換嗎? 可以的, 但是要使用一點路由資訊的小技巧! 假設公司內部都是 192.168.0.0/16 範圍內的網段. 首先將有線和 Wireless LAN 分配成不同的 IP 網段. Windows 這端的設定, 就必須是 "192.168.0.0/255.255.0.0" 路由指向有線的 LAN 網段閘道器 IP 位址; 然後將 Windows 的預設路由 (Default route) 指向 Wireless LAN 網段的閘道器 IP 位址.

看出關鍵了吧! 因為 192.168.0.0/16 是更精準的路由資訊 (more specific route), 所以平常都會走有線的 LAN, 直到 Switch 故障的時候, 才改透過預設路由走 Wireless LAN, 完成全自動切換.

應該有很多 "自動的方式" 可以將以上兩個路由分開, 可以用 Windows 本身的群組規則 (Windows AD Group Policy) 可以做到; 簡單一點的話, 其實 DHCP 就可以了!

以上的做法可以解決 Intranet 自動備援的問題. 一定有朋友想到了, 如果還要同時做到上 Internet 也是自動備援呢?

先賣個關子, 下一篇再聊!

2009年5月15日 星期五

Redundancy: 我也上了一課

應該很多朋友已經注意到, 本站的有些 .PKT 檔案和圖檔, 這一兩天沒有辦法下載. 這是因為我部分的內容是放在外面 (而且唯一) 的一家 Web Hosting 公司的伺服器上. 他們目前已經停機超過 24 小時了!

在此要跟各位說聲抱歉! 因為的確有些重要檔案我沒有備份, 所以部分內容可能還要更久才能回復.

平常都是我在教別人, 結果我對我自己網站的內容並沒有遵守相同的紀律. 這次的事件給我自己也好好地上了一課!

2009年5月14日 星期四

有必要如此生氣嗎?

我在 Mobile01 看到一群人在討論, 標題是 "我受夠了!!!為了看網路電視別人的權益都不管了嗎?", 整個故事的背景是有人在抱怨, 幾位室友分租上 Internet 的線路, 但是老是有室友不合作, 執行網路電視的軟體或 P2P 軟體, 讓大家上網都很慢. 然後有些熱情的網友就開始提供一些奇怪的方法, 有些甚至是違法的行為 (請勿模仿, 公共危險罪可是公訴罪) 來讓這位不合作的室友停止這種行為.

其實他們的討論是多餘的, 安裝一部 Cisco Router 就可以輕易的達成 "每個室友頻寬使用量鎖定" 的目標.

(當然, 有些國產品牌的寬頻分享器也有這種功能, 我先將焦點放在 Cisco 產品的技術上.)

各位可以使用 Cisco 新的 "模組化品質管制服務設定介面" (Modular QoS CLI, MQC) 來完成, 以下是設定的範例:

!
! 對每位室友設定 IP 位址辨認條件, 我先假設就兩位室友
!
access-list 101 permit ip host 192.168.1.1 any
access-list 102 permit ip host 192.168.1.2 any
access-list 111 permit ip any host 192.168.1.1
access-list 112 permit ip any host 192.168.1.2

!
! 定義類別, 分上下行
!
class-map Roommate1-Up
 match access-group 101

class-map Roommate2-Up
 match access-group 102

class-map Roommate1-Down
 match access-group 111

class-map Roommate2-Down
 match access-group 112

!
! 組合成一套品質服務內容 (policy-map)
! 我先假設下行給 500K, 上行給200K. "police" 命令的單位是bps.
!
policy-map Up
 class Roommate1-Up
  police 200000 conform-action transmit exceed-action drop
 class Roommate2-Up
  police 200000 conform-action transmit exceed-action drop

policy-map Down
 class Roommate1-Down
  police 500000 conform-action transmit exceed-action drop
 class Roommate2-Down
  police 500000 conform-action transmit exceed-action drop

!
! 將品質服務內容套用在網路卡上
!
int f0/0
 ip address 192.168.1.254 255.255.255.0
 service-policy input Up
 service-policy output Down


當然以上的例子, 在我們的 ICND 課程當中是沒有的, 這算是 QoS 課程的內容才會提到!

2009年5月12日 星期二

備援的重要性 - 從捷運看網路設計

Four Sisters in Pinks (DSC_0027)
Four Sisters in Pinks (DSC_0027),
originally uploaded by Li-Ji.
就在今天早上上班的尖峰時間, 我經過 "捷運台北車站", 看到直通的第二層淡水/新店線月台的電扶梯故障了! 一群工作人員正緊急搶修中! 我相信今天有不少人都有目睹到這一幕! 還好的是, 還有樓梯可以走, 還有另外一條電扶梯也可以到, 所以即使是最快的這條路斷了, 經過工作人員的疏導, 乘客的影響並不大!

想像一下, 假設當初設計 "捷運台北站" 的工程師, 所有通道都只有一條路, 結果遇到了今天的狀況發生, 那就變成所有的乘客都沒辦法在尖峰時間進入到淡水/新店線月台! 我相信引來的抱怨聲浪, 肯定是會上報紙的!

我們在規劃網路建置時, 一定都要包含到多重備援路徑! 沒有單一線路是永遠不會斷的! 避開單點故障全系統故障 (Single Point of Failure) 的設計, 絕對會讓各位的網路工作和生活過得更平安一點!

我將上課補充的 Packet Tracer 檔案文章, 整理在右邊第二版面當中

(Jan 6, 2012 更正: 已經搬到畫面的正下方! 歡迎繼續多加利用!)

相信眼尖的朋友已經注意到了! 怕大家沒有看到, 還是多提醒一下!

這些檔案是我在教 Cisco 網路學院班時做給學生練習用的, 我相信對其他的朋友, 甚至是老師, 也許多少有些幫助, 所以乾脆整理清楚一點, 方便大家隨時點選!

歡迎大家多多利用, 也請多批評指教!

2009年5月11日 星期一

Fw: 在職學習高手—交大計算機與網路中心組長高義智


「學習永無止盡,對我來說,是一件最快樂的事!」

很榮幸有機會跟這位前輩高義智 (Patrick) 一起在 HP 當過近兩年的同事, 他是我 HP 的入行指導師 (Mentor), 我從他哪裡學到非常多的事情. 我後來會進入 "Cisco 教學領域", 也是經由他的牽線而促成的. 他真的是我的貴人!

記者的這篇報導, 描述得一點都不誇張, 他真的是證照一張接著一張考到, 學位也是拿完一個又一個的!

至於記者提到的那個大型連鎖超商客戶, 是我所遇過的客戶裡面最難應付的, 但是只有他"罩"得住! 只要他一出面, 客戶就都沒問題了! 不只這個, 很多客戶即使遠在新竹, 台中, 甚至高雄, 他也常常是一通電話, 就 "飛" 下去順利解決!

很傳奇的人物吧! 話不多說, 就讓各位自己看看吧! (一共四頁, 要看完喔!)

在職學習高手—交大計算機與網路中心組長高義智
撰文◎李翠卿 攝影◎葉俊嘉  2008-11-04
【Career職場情報誌】第391期

2009年5月7日 星期四

STG: 每秒取樣的即時流量觀察工具

當遇到應用服務效能變慢的時候, 我們都會需要一個工具, 來告訴我們現在某張網路卡 (Interface) 即時的瞬間流量是多少, 來確認 (或排除) 是這張網路卡的流量超載影響效能.

我這裡提供一個免費的小工具的資訊. 它的名字叫做 STG (SNMP Traffic Grapher).



2009年5月6日 星期三

"H1N1" 來襲時, 你和你的公司都做好準備了嗎?

Tunnel to the sea (DSC_0132)
Tunnel to the sea (DSC_0132),
originally uploaded by Li-Ji.
當年 SARS 來襲時, 如果有人疑似感染, 整個辦公室的人員都必須在家裡或是就地隔離. 當時的政府想到了 "第二辦公室" 的概念: 也就是說, 人員和正副主管是分散在兩個(或以上)的辦公室中辦公, 才不會只因一個員工感染, 唯一的那個辦公室就完全不能辦公.

"H1N1" 也許不久後就會跟當年的 SARS 一樣散布開來. 我們 "網路人" 在這個時候, 有甚麼工作, 是現在就可以做的? 我這裡提幾個建議, 是各公司可以立刻努力的方向:

(1) 建立第二辦公室. 模仿一下政府的作法, 這是很有效的. Intranet 建立不困難, Internet 的應用可能就比較複雜, 甚至可能需要修改軟體. 如果過去就有第二辦公室的朋友, 就趕快做一下演習吧! 你應該會需要新的路由器, 交換器, 申請新的線路, 或是需要 "跨據點負載平衡器" 來完成這些功能.

(2) 機房無人化. 機器並不會感染 "H1N1", 如果可以讓你機房裡面的各種有形或無形的 "資訊資產", 透過 "網路" 就可以存取管理, 那即使在家自我隔離的同事, 都還可以連進來辦公. 你應該會需要 SSL VPN 閘道器, 管理軟體, 遠端桌面工作軟體.

(3) 視訊會議與協同作業平台. 通常分離兩地的正副主管和員工間, 特別需要這個服務來開會溝通. 你應該會需要視訊會議的設備, IP語音通訊軟硬體, 和協同作業平台系統.

(4) 非主要系統透過 Internet 委外. 例如有些公司的 Email 系統, 教育訓練系統, 差勤公文系統等比較沒有資料外洩的顧慮的 那就讓它們都 Internet 化吧! 很多公司, 甚至外國公司, 都可以提供相對應的委外服務.  其實這樣的做法, 就是最近很熱門的 "雲端運算" (Cloud Computing) 概念的實踐!

希望 "H1N1" 並不會擴散開來, 但是 "網路人" 還是趕快要做好準備, 不幸真的來了, 就不會束手無策!

2009年5月4日 星期一

第五屆華陀盃網路技能競賽開始受理報名

我今天收到 Cris 的 Email. 歡迎大家踴躍報名參加!

主旨: 第五屆華陀盃網路技能競賽開始受理報名


網路遨遊探資訊  疑難排解論英雄
第五屆華陀盃網路技能競賽正式開跑!!
歡迎老師帶隊與學生共同探索網路世界的各項驚奇與挑戰
即日起接受報名.報名網址:http://catc.nctu.edu.tw/contest2009/
報名時間及方式:即日起至98710日止,請至活動網址報名
報名資格:97學年度在學或應屆畢業之大專院校學生,兩人為一組
報名費用 : 思科網路學會會員學校每組600元,非學會學校每組800元
          (比賽當日現場繳交,現場開立收據,費用內含每人午餐,T-Shirt乙件,及當日安全保險費用)
比賽日期:98717日(星期五)
比賽地點: 中國文化大學推廣教育部(台北市建國南路二段231)
競賽方式初賽:線上問答、現場搶答、 Packet Tracer模擬軟體解題競賽
         決賽:LAB實機操作競賽(依初賽成績評選10組隊伍進入決賽)
本競賽冠軍隊伍將代表台灣參加思科網路學會亞太區網路技能競賽,與其他國家菁英一較高下,為國爭光!!
獎項說明冠軍隊伍將獲頒獎狀及15,000元獎金
         亞軍及季軍隊伍將獲頒獎狀及獎金
         其他入選決賽之隊伍將獲頒獎狀及禮卷
主辦單位:中國文化大學/國立交通大學
協辦單位:台灣思科系統股份有限公司/ 台灣思科網路學會議評會/思科網路學會
贊助單位:麟瑞科技股份有限公司/Training Partners認證學院
對活動有任何建議請洽
中國文化大學林老師 (pclin@sce.pccu.edu.tw)及思科網路學會Cris (crichin@cisco.com)


Cisco IOS Router/Switch 使用 TELNET 備份設定

Aboriginal Art and Ponds (DSCN0211)
Aboriginal Art and Ponds (DSCN0211),
originally uploaded by Li-Ji.
使用 HyperTerminal 在 Console 上備份設定, 上課一定都有練習過. 不過日常的網路維護, 反倒是很難有機會使用 Console: 因為 Router/Switch 通常都鎖在 "遠處, 門禁森嚴" 的機房中.

我常用一個小技巧, 只可惜這招只能在 Windows XP 上使用.

TELNET -F log-file.txt 192.168.1.1

其中 "log-file.txt" 就是畫面記錄檔的名稱. "192.168.1.1" 就是你的 Router 或 Switch 的 IP 位址. 接下來應該如何各位應該就很熟練了!

enable
terminal length 0
show run
show start

各位應該還記得要將終端機行數 (length) 設成是 0, 意思就是不要有 "--- MORE ---" 分頁的功能!


2009年5月1日 星期五

如何搜尋本站張貼的內容當中, 有提到 "OSPF" 的文章?

其實 Blogger.com 一直都有一個搜尋工具, 只不過真的很不顯眼, 我也是用了一段時間以後才發現: 其實就藏在最上頭的 "Search Blog" (或顯示為 "搜尋網誌") 按鈕當中, 左方空格直接填入關鍵字, 然後按下該按鈕. 如下圖所示:




搜尋結果, 請注意會出現下面的這個畫面, 代表是搜尋結果:



請注意, 這時候 "網址列" 變成是這樣:

http://showipprotocols-tw.blogspot.com/search?q=ospf

這樣大家應該就看得出規則來了!

所以, 如果習慣在瀏覽器的網址列直接下命令的話, 就可以用 "/search?q=關鍵字" 的方式來搜尋了!

如果各位比較習慣使用 Google.com 搜尋的話, 也是可以的, 請在關鍵字後面, 多加上 "site:showipprotocols-tw.blogspot.com" 的方式即可. 不過, Google.com 的資訊會比各位直接在 Blogger.com 上搜尋出來的結果, 內容會稍微不即時一些.

http://www.google.com/search?q=ospf+site:showipprotocols-tw.blogspot.com


另外要請大家注意: 以上方法這個方法, 都只能搜尋本站內部的內容. 至於進一步的搜尋方式, 留待下次在聊了!

2009年4月30日 星期四

怎麼會忽然 "動態取得" 一個怪怪的 IP 位址? (DHCP Snooping)

其實就是有人在你的網段中, 不小心打開了 DHCP Server 功能. 最常見的原因, 就是因為網路孔位不足, 有人自己去電子商場買了 "寬頻分享器" (Cheap, SOHO, Broadband Router). 通常他們的 DHCP 服務預設都是打開的, 而且都是 192.168.1.0/24 這個網段. 所以這些怪怪的 IP 位址, 通常都是長得這個模樣: 192.168.1.X.

而且整個網段, 通常會"部分取得正確, 部分取得錯誤". 我相信很多網管工作者都有遇到過這種窘境.

如何防範, 其實在各位的 Cisco 2950 以上的 Switch 就支援的 DHCP Snooping 功能, 正是為了解決這個問題而來的! 打開以後, 不管再有誰做這種事, 也不會發生錯誤取得IP位址的問題!

DHCP Snooping 的原理簡單的來說, Switch 會監看 DHCP 的活動, 就是只允許指定的部分 Switch Port 放行 DHCP伺服器的回應封包, 其他的一律不准. 所以只會取得指定 Server 回應的 DHCP 內容.

注意: 有一點很重要, 如果 DHCP Server 不是接在本 Switch 時, Uplink port 請務必要允許 DHCP Server 回應, 不然整台 Switch 上的 PC 都會收不到動態的 IP位址資訊!

另外, 因為設定過程會影響 DHCP 運作, 建議最好是在下班時間再啟動這個功能!

以下是典型的設定:
! Global, 啟動 DHCP Snooping, 這行一定要
 ip dhcp snooping

! 假設只對 VLAN 100 和 VLAN 200 作 DHCP 設限, 這行也一定要
 ip dhcp snooping vlan 100 200

! DHCP Server 埠, 或是 Uplink, 這點很重要, 不然會全部都收不到!
 interface GigabitEthernet0/1
  ip dhcp trust

! 一般使用者埠, 這是預設值, 可以不用下
 interface FastEthernet 0/1
  no ip dhcp trust

[Reference]
DHCP Snooping Configuration Guidelines section of Configuring DHCP Features, on Cisco.com


2009年4月28日 星期二

Windows 上啟用 SNMP 服務

我在作業系統為 Windows XP Pro 和 Windows Server 2003 上面有試過是成功的, XP Home 我就不確定, 有待網友補充!

我以下先用 Windows XP Pro 舉例, 至於其他版本的 Windows, 原理應該是一樣的!

簡單的步驟如下
  1. 安裝SNMP服務軟體. 從 "控制台"\"新增移除 Windows 元件"\"Management and Monitoring Tools"\"Simple Network Management Protocol"
  2. 建議最好接著更改群組代碼允許查詢的來源 IP位址.

我也將幾個關鍵畫面貼給各位參考!

2009年4月27日 星期一

VUE: Cisco 重考一次優惠: “Specialize” Promotion

一樣是可重考一次, 但是僅限於以下幾個 CCNA Specialization:
  • 640-460 IIUC CCNA Voice
  • 640-553 IINS CCNA Security
  • 640-721 IUWNE CCNA Wireless

有效期間跟之前的狀況一樣, 我都找不到官方資訊! 很有可能都是 2009 年 7 月中. 如果還沒考過 CCNA和相關考試的朋友, 建議要好好利用!


[Reference]



2009年4月21日 星期二

唱首歌, 來告訴你甚麼是 "Spanning Tree"!



這首詩歌的詞, 正是 Radia Perlman 本人. "她" 正是發明 "Spanning Tree" 的那位博士. 至於 Piano 曲是否真為本人, 那我就不知了!

Algorhyme

I think that I shall never see
A graph more lovely than a tree.

A tree whose crucial property
Is loop-free connectivity.

A tree that must be sure to span
So packets can reach every LAN.

First the root must be selected.
By ID, it is elected.

Least-cost paths from root are traced.
In the tree, these paths are placed.

A mesh is made by folks like me,
Then bridges find a spanning tree.


- Radia Perlman

http://books.google.com/books?id=AIRitf5C-QQC&pg=PA58&vq=spanning+tree&dq=book+interconnections+spanning+tree&source=gbs_search_s&cad=0

On Page 58.

2009年4月19日 星期日

設定啟動 IPv4 和 IPv6 共存, 並同時提供完整連通性 (CNA-04-006)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-006), 設定啟動 IPv4 和 IPv6 共存, 並同時提供完整連通性.




這個例子主要是讓大家練習, IOS IPv6 的相關命令, 和啟動 IPv6 路由交換協定的新方法.

(請注意, Packet Tracer Version 4.X 並不支援 IPv6, 所以請務必使用 5.X 以後的版本!)

網路卡的位址我已經幫各位加上去了, 各位只需要觀察就好!

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1:1:1::1/64
!
interface Serial0/0/0
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:2:2:2::1/64
 clock rate 64000
!

路由資訊交換協定, 則要各位自己加. 啟動 IPv4 RIPv2 應該難不倒各位, 只要按照基本兩步驟即可:
  1. 先用 "router X" 命令, 帶起路由資訊交換協定的軟體
  2. 再用 "network Y" 命令, 指名哪些網路卡要啟用這個協定軟體

router rip
 version 2
 network 10.0.0.0
 no auto-summary
!

當然以本例來說, 剛好並不需要 "no auto-summary", 不過, 養成好習慣也不錯!

至於 IPv6 的 RIPng 的部分, 設定的方式就和 IPv6 有很大的不同:
  1. 還是需要先帶起該協定的軟體, 但是這時候就要取個名字了(標籤, TAG), 因為可以支援多份 (Multiple Instance)
  2. 直接到網卡指名, 要不要啟動該協定軟體, 的哪一個 Instance

interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1:1:1::1/64
 ipv6 rip CCNA enable 
!
interface Serial0/0/0
 ip address 10.2.2.1 255.255.255.0
 ipv6 address 2001:2:2:2::1/64
 ipv6 rip CCNA enable 
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
ipv6 router rip CCNA
!

請注意, 本例中的標籤 "CCNA" 僅為內部識別使用! 所以各位還可以自己玩一下, R1 和 R2 使用不同的標籤名稱, 來驗證一下這件事!

2009年4月16日 星期四

讓我們一起為他加油吧!

Purple Lotus (DSCN1136)
Purple Lotus (DSCN1136),
originally uploaded by Li-Ji.
我們之間的一位朋友, 今天要去參加好不容易才等到的一次工作面試.

讓我們一起為他加油吧!

2009年4月14日 星期二

設定 Cisco IOS 位址轉譯功能 (NAT and PAT), 來讓內部使用者可以連上 Internet (CNA-04-005)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-005), 設定 Cisco IOS 位址轉譯功能 (Network Address Translation, NAT, and Port Address Translation, PAT), 來讓內部使用者可以連上 Internet.




這個練習的圖和定址其實和前面的 ACL 例子一模一樣, 我們還是拿 R0 當做 Internet, 只不過將 R0 和 R1間的EIGRP拿掉. 並在 R1 上加入 Default route, 指向 R0 (Internet).

一開始, 下方的兩個網段的任何PC或是Switch, 都是沒有辦法連線到 R0 (Internet) 的, 這是因為 R0 根本就沒有這兩個網段的路由資訊. 除非, R1 可以將下方兩個網段的 PC 或是 Switch 出發的連線的來源位址, 都轉譯成 10.1.1.0/24 網段內的 IP 位址, 那才有機會成功連線!

所以各位還記得 NAT 和 PAT 的基本三設定要素:
  1. 指明 Inside 網卡: 從哪些網卡進來的封包, 它們的位址需要被轉換
  2. 指明 Outside 網卡: 從哪些網卡進來的封包, 它們的位址需要被還原
  3. 指明位址轉譯規則: 這點 NAT 就和 PAT 不同, 而且有好幾種模式

前兩個步驟 NAT 和 PAT 都一樣
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.11.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.0
 ip nat outside
 clock rate 64000
!

[PAT]

第三步就不同, 我先說明 PAT. PAT 提供的功能, 就是要盡量節省 IP 位址的使用, 所以就直接拿 R1 的 S0/0/0 IP 位址來給大家共用, 但是利用 TCP 和 UDP 的 Port 號來區別, 哪一個封包該還原回哪一個位址.

另外, ACL 在這裡又派上用場, 當成篩選封包的條件: 如果篩選結果是 "permit", 那就幫你 PAT, 反過來如果是 "deny", 則 不 幫你 PAT.

關鍵設定如下:


ip nat inside source list 100 interface Serial0/0/0 overload
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
access-list 100 permit ip 192.168.11.0 0.0.0.255 any
!

以下是轉譯的觀察, 我分別從兩台 PC, TELNET 到 R0, 在 R1 上看到的結果.

R1>show ip nat translation
Pro  Inside global     Inside local       Outside local      Outside global
tcp 10.1.1.1:1024      192.168.10.10:1025 10.1.1.2:23        10.1.1.2:23
tcp 10.1.1.1:1025      192.168.11.10:1025 10.1.1.2:23        10.1.1.2:23

R1>


從 R0 上看更清楚, R0 以為是來自 10.1.1.1 的兩個連線.

R0>show user
    Line       User       Host(s)              Idle       Location
* 67 vty 0                idle                 00:00:00 10.1.1.1
  68 vty 1                idle                 00:01:48 10.1.1.1

  Interface    User               Mode         Idle     Peer Address
R0>

[NAT]

NAT 指的是上網的 PC 各自完全佔用一個 IP 位址. 所以設定上也不同. 我先假定有連續一整段的 IP 位址可以供分配來使用: 10.1.1.101 到 10.1.1.200.

請注意, 單純的 NAT, 是完全佔用一個 IP 位址, 所以, 先搶先贏, 搶不到的人, 就完全沒有位址可以上網! 本例子中, 只有前 100 名有位址可用. 第 101 位使用者起, 就只好說抱歉了!

關鍵設定如下:

ip nat pool INET-POOL 10.1.1.101 10.1.1.200 netmask 255.255.255.0
ip nat inside source list 100 pool INET-POOL
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
access-list 100 permit ip 192.168.11.0 0.0.0.255 any
!

跟前面一樣, 以下是轉譯的觀察, 我分別從兩台 PC, TELNET 到 R0, 在 R1 上看到的結果.

R1>show ip nat translation
Pro  Inside global     Inside local       Outside local      Outside global
---  10.1.1.101        192.168.10.10      ---                ---
---  10.1.1.102        192.168.11.10      ---                ---

R1>

從 R0 上看更清楚, R0 以為是 分別來自 10.1.1.101 和 10.1.1.102 的兩個連線.

R0>show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00 
  67 vty 0                idle                 00:01:45 10.1.1.101
  68 vty 1                idle                 00:01:35 10.1.1.102

  Interface    User               Mode         Idle     Peer Address
R0>

2009年4月13日 星期一

時機不好, 更要增加自我學習的份量

Open wide and full (DSCN0634)
Open wide and full (DSCN0634),
originally uploaded by Li-Ji.
時機不好, 讓人不管是身處在哪一個行業, 或是遇到了哪種狀況, 多少都會感覺到: 時間忽然變多了!

從另外一個角度來想, 時間變多, 不就正好就是學習充電的好機會! 以下我舉一些可以嘗試的方向:

  1. 我課堂有提過的 Cisco 官方學習網站, 是否應該多花點時間去逛逛? 順便練練英文溝通也不錯!
  2. 如果可以爭取得到公司的贊助, 去上上課也不錯! 例如直接在上方的 Google自訂搜尋中搜尋 "ccnp", 就會得到不少課程資訊了!
  3. 用 Email 訂閱本網站, 告訴我你想知道哪些新資訊, 讓我可以多寫些內容給各位看!

其實還是要鼓勵大家多多訂閱本網站啦! 我準備了一份小小的神秘禮物, 只要在今年2009年12月31日之前使用 Email 訂閱成功的朋友,每位都可以得到! 現在已經 Email 訂閱的老朋友也有喔!

歡迎大家廣為宣傳!


2009年4月7日 星期二

使用存取控制清單 (Access Control List, ACL), 來限制 Internet 進來的連線 (CNA-04-004)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-004), 使用存取控制清單 (Access Control List, ACL), 來限制 Internet 進來的連線.




這個例子我們必須使用 "延伸式ACL" (Extended ACL). 這是因為來自相同 IP 位址的封包, 有不同的權限: ICMP 可以過, 但是 TCP 的 port 23 TELNET 不能過.

至於ACL的內容, 我使用以下的方式給各位參考:


interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.0
 ip access-group 100 in
 clock rate 64000
!
access-list 100 deny tcp any 192.168.0.0 0.0.255.255 eq telnet
access-list 100 permit ip any any

這個例子是套用在 "Serial0/0/0" 其實相同的 ACL 也可以只套用在 "FastEthernet0/0" 和 "FastEthernet0/1", 效果相同.

2009年4月6日 星期一

使用 TFTP 還原 IOS 映像檔, 與設定內容的備份/還原練習 (CNA-04-003)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-003), 使用 TFTP 還原 IOS 映像檔, 與設定內容的備份/還原練習.




這個例子純粹只是提供一個簡單的 Packet Tracer 環境, 讓大家可以練習與感覺一下, Cisco IOS 映像檔 (Image file) 如何還原, 與設定內容 (Configuration) 的備份與還原.

不過, 如果各位有真實的 Router/Switch, 還是盡量以真實的機器練習, 畢竟 Packet Tracer 只是模擬器! 同時還少了很多, 例如 IOS 映像檔備份這個方向的練習。

[In Packet Tracer 5.0]


Cisco-Switch-2960>en
Cisco-Switch-2960#copy ?
  running-config  Copy from current system configuration
  startup-config  Copy from startup configuration
  tftp:           Copy from tftp: file system
Cisco-Switch-2960#copy tftp: ?
  flash:          Copy to flash: file system
  running-config  Copy configuration from system
  startup-config  Copy startup configuration from system
Cisco-Switch-2960#
[In real Cisco 2960 switch]
Cisco-Switch-2960#copy ?
  /erase          Erase destination file system.
  /noverify       Disable automatic image verification after copy
  bs:             Copy from bs: file system
  cns:            Copy from cns: file system
  flash:          Copy from flash: file system
  ftp:            Copy from ftp: file system
  null:           Copy from null: file system
  nvram:          Copy from nvram: file system
  rcp:            Copy from rcp: file system
  running-config  Copy from current system configuration
  startup-config  Copy from startup configuration
  system:         Copy from system: file system
  tftp:           Copy from tftp: file system
  xmodem:         Copy from xmodem: file system
  ymodem:         Copy from ymodem: file system

Cisco-Switch-2960#copy tftp: ?
  flash:          Copy to flash: file system
  null:           Copy to null: file system
  nvram:          Copy to nvram: file system
  running-config  Update (merge with) current system configuration
  startup-config  Copy to startup configuration
  system:         Copy to system: file system

Cisco-Switch-2960#

2009年4月1日 星期三

Frame-Relay 搭配 RIP 的問題設定與解決 (CNA-04-002)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-002), Frame-Relay 搭配 RIP 的問題設定與解決.




當然我上課中並不鼓勵大家繼續使用 RIP, 不過這是一個典型的 "Frame-Relay + RIP" 的老問題, 所以還是提出來讓大家認識一下問題所在.

這個例子中, 我們只有兩條 Virtual Circuit 可以用, 分別是 "Router 1/Router 2 間", 與 "Router 2/Router 3 間".

Frame Relay 的設定並不困難, 只要在 Serial 網卡 Encapsulation 改成 "frame-relay" 即可. 以 Router 1為例:


interface Serial0/0/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay

稍等一下子, 等 Cisco 的反向 ARP (Inverse ARP) 資料同步後, 這三部路由器之間是可以透過 Serial 網卡的 IP 位址連線得到. 以 Router 2 為例:


R2#show frame-relay map
Serial0/0/0 (up): ip 10.1.1.1 dlci 201, dynamic, broadcast, CISCO, status defined, active
Serial0/0/0 (up): ip 10.1.1.3 dlci 203, dynamic, broadcast, CISCO, status defined, active
R2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/60 ms

R2#ping 10.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/54/91 ms

R2#

但是問題來了, 如果只是單純地啟動 RIP, 那我們就會發現, Router 1 永遠收不到 Router 3 身後的網段, 反之亦然:

R1>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 10.1.1.2, 00:00:23, Serial0/0/0
R1>

其實原因就是卡在 Router 2. 以這個例子, 因為我們只有兩條 Virtual Circuit 可用, 所以 Router 3 的路由資訊只有 Router 2 收得到, 除非 Router 2 "主動" 再將 "從 Router 3 收到的資訊" 再傳給 Router 1, 否則 Router 1 就會永遠收不到 "Router 3 身後的網段資訊".

為何 Router 2 不送, 這是因為 "分割視野 (Split Horizon)" 起了作用, Router 2 認定 Router 3 送出的資訊是由 "Serial 0/0/0" 進入, 所以按照 "分割視野" 的規則, 這些資料就都不會再從 "Serial 0/0/0" 透過 RIP 送出. "分割視野" 預設是啟動的, 這正是為什麼 Router 1 收不到的原因!

所以這個現象的正解, 就是要在 Router 2 的 "Serial 0/0/0" 上面, 我們必須取消 "Split Horizon" 的功能, 像這樣:

interface Serial0/0/0
 ip address 10.1.1.2 255.255.255.0
 no ip split-horizon
 encapsulation frame-relay

如此一來就可以正常使用 Frame Relay + RIP.

不過當然, 還是強烈建議使用 EIGRP 或是 OSPF, 她們都不會有這類問題. 除非萬不得已才使用 RIP, 再參考本例來解決這種怪問題.

2009年3月31日 星期二

設定 PPP 與 CHAP 身份驗證 (CNA-04-001)

CCNA Exploration 4.0 第四學期上課檔案 (CNA-04-001), 設定 PPP 與 CHAP 身份驗證.




這是一個簡單的練習, 純粹就是讓大家再練習一下, 設定 PPP 與 CHAP 身份驗證的設定. 其實我在之前的這篇文章有提到過, CHAP 的方向很容易弄錯. 所以兩相比對, 應該難不倒大家!

2009年3月24日 星期二

VUE: Cisco 認證考試, 可以重考一次優惠

告訴大家一個好消息: Pearson/VUE 提供 "重考一次" 的優惠. 也就是說, 如果第一次沒有通過沒關係, 還可以免費考第二次!

我還沒確定這項優惠到什麼時候為止, 不過, "晨宇資訊" 提供有相同功能的考試券, 只是有效期限很短:

注意事項:本優惠專案考試券須於2009年4月25日前購買並於2009年7月25日前使用完畢。

CCNA, CCNP各科目都包括在內喔!

[Reference]

如何重考一次: 報名考試結帳前一個畫面, 輸入 promotion code: COMEBACK2009
http://vue.com/cisco/comeback2009/

晨宇資訊廣告:
http://www.itlearningsolution.com/big5/edm_0131/it_edm_980319.html


2009年3月22日 星期日

利用具備一個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性 (CNA-03-007)

CCNA Exploration 4.0 第三學期上課檔案 (CNA-03-007), 利用具備一個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性.




一個 LAN 埠如何提供三個 VLAN 的連通性? 這需要一點額外的設定. 簡單的說, 如果路由器看得懂 Switch 用來做記號的 VLAN 標籤, 那這部路由器, 就可以在上面也提供 "虛擬的" 網路卡 (Virtual Interface), 在各 VLAN 上, 同樣可以提供各 VLAN 間的連通性.

路由器要如何看得懂, 首先是硬體必須支援, 至少必需是 100Mbps. 不過只要是最近新買的路由器都沒有這個問題, 除非是早期的 Cisco 2600 時代的產品.

關於路由器的設定, 其實只要多宣告 "sub-interface" 即可":


interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.100
 encapsulation dot1Q 10
 ip address 172.17.10.1 255.255.255.0
!
interface FastEthernet0/0.200
 encapsulation dot1Q 20
 ip address 172.17.20.1 255.255.255.0
!
interface FastEthernet0/0.300
 encapsulation dot1Q 30
 ip address 172.17.30.1 255.255.255.0
!

其中, 10, 20, 30 分別是 VLAN 的號碼. 802.1Q 是標籤的格式. "Sub-interface" 的號碼, 倒是不需要和 VLAN 號碼一樣. 本例中我故意取不同的號碼.

至於 Switch 端, 接路由器的這個埠, 必須設定成主幹模式 (Trunk Mode), 這樣各 VLAN 的訊框, 才會被加上標籤送給路由器.


interface FastEthernet0/11
 switchport mode trunk
!

這樣的設定, Cisco 網站習慣稱呼它為 "Router-on-a-stick", 也就是一隻腳的路由器!

這種配置同時解決一個問題, 如果我們還必須連接更多 VLAN, 那麼還是只需要一個 LAN 埠即可! 否則, 每多一個 VLAN, 就要多一張網卡, 那就會有很多問題. 試著想想如要多加入 100個 VLAN 的狀況會是如何!

2009年3月20日 星期五

CCNP工作機會, 台灣某系統整合公司 (三名)

Pink Lotus (DSCN1239)
Pink Lotus (DSCN1239),
originally uploaded by Li-Ji.
如果您已經通過 CCNP 認證, 而且想進一步挑戰新工作 (台灣), 請直接 Email 您的履歷表電子檔給我! 另外也請告知手機電話號碼, 讓我可以直接跟您聯絡!

以前是我的班上的朋友, 應該都知道我個人的 Email, 如果是其他朋友想知道, 建議請直接點選畫面右上角 "Email 訂閱收看本Blog", 你很快就會知道!

2009年3月19日 星期四

利用三個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性 (CNA-03-006)

CCNA Exploration 4.0 第三學期上課檔案 (CNA-03-006), 利用具備三個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性.

 



我們之前是將各 VLAN 分開, 現在是將她們連接起來.當然大家都知道, 要將分離的 第二層 VLAN 連接起來, 只能透過 第三層的路由器 (Router) 連接.

因為只有三個 VLAN, 所以只要使用三隻腳的路由器即可. 設定應該不困難, 容易漏掉的是, 路由器的 LAN 埠所接上的 Switch 埠, VLAN 號碼要設對, 要和被服務的 PC 所接的 Switch 埠 VLAN 號碼一樣. 另外 Switch 間的連線也要改成是主幹模式 (Trunk Mode).

2009年3月18日 星期三

觀察並設定涵蓋樹狀結構 (Spanning-Tree) 的樹根 (Root) (CNA-03-005)

CCNA Exploration 4.0 第三學期上課檔案 (CNA-03-005), 觀察並設定涵蓋樹狀結構 (Spanning-Tree) 的 樹根 (Root).




分離兩個 Layer 2 的世界, 和之前的許多例子一樣, 應該不困難.

這個例子主要是在讓大家觀察, 涵蓋樹狀結構 (Spanning-Tree) 的樹根 (Root) 如何觀察, 和如何設定.

扮演 "樹根" 腳色的交換器, 將會是"被廣播出來的訊框"負載最高的那一台交換器, 所以誰來扮演, 會影響整體的效能. 所以通常我們都是指定 "最貴的那台交換器", 來當 "樹根".

在還沒有做任何設定調整前, "樹根" 腳色是由交換器本身出廠的 MAC 位址決定: 數字最小的就是 "樹根". 以本例子來說, 各位會發現不論是任何 VLAN, "樹根" 都是 S2. 以下用 VLAN1 當例子:

S2#show spanning-tree 
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0002.4AEE.B73B
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0002.4AEE.B73B
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/11           Desg FWD 19        128.11   P2p
Fa0/18           Desg FWD 19        128.18   P2p

S2#

本例子中, 假設我們希望將 S1 指定為 VLAN 10 的 "樹根", 但是同時, 將 S3 指定為 VLAN 20 的 "樹根". 那我們可以分別下以下 IOS 命令: (show run 會看不到, 各位要親自下下看!)

S1(config)# spanning-tree vlan 10 root primary

S3(config)# spanning-tree vlan 20 root primary

各位可以從命令的關鍵字猜的出來, 其實還有一個 "secondary" 的命令. 這也就是說, 我們也可以指定 "副班長": 備援的 "樹根候選人", 當 "樹根" 出問題時, 可以馬上接手

假設我們希望 S1 幫忙做 VLAN 20 的備援 "樹根"; S3 幫忙做 VLAN 10 的備援 "樹根", 那我們可以多下以下命令:
S1(config)# spanning-tree vlan 20 root secondary

S3(config)# spanning-tree vlan 10 root secondary

如此一來, 我們就可以精準地指定誰來當 "樹根", 減少效能的問題了!

2009年3月6日 星期五

CCIE 榜單

剛才在這篇連結到這個網站, 上面是所有有效的CCIE人的名字列表. 讓我想起當年為了這個號碼, 沒日沒夜地準備Lab的考試, 而且三次飛進去新加坡 Lab 考場, 才拿到這個號碼. 所有的感受和回憶, 一下子都湧上心頭!

8299 - Li-Ji Hong (1,Routing and Switching)

http://cciehof.weebly.com/

到現在還是有很多人在追求這個號碼, 希望這些人都能如願以償!

2009年2月20日 星期五

Cisco SDM 執行問題: Java Runtime

我之前在這篇有提到 Cisco SDM 的個人練習環境. 當時我忘了紀錄 Java 的版本 (版本我也忘了!), 結果, 上課時我就真的出糗了!

我安裝了最新版的 Java Runtime Time ("JRE 6 Update 12"), 結果當著全班的面, Cisco SDM 沒辦法成功執行.

後來我找到 Cisco 網站的這篇註記, 結果發現 "JRE 1.5.0_07" 和之前的版本, 是有支援的, 所以是完整測試過的. 我 JRE 一降版成 "JRE 1.5.0 Update 17", 馬上就OK!

所以 SDM V2.3.2 必須搭配 "JRE 1.5.0 Update 17", 才能順利執行!

有時間的話, 我再試一下幾個 "版本/JRE" 的組合, 結果再跟大家報告! 也歡迎大家提供資訊!


[Reference]

SDM V2.3.2 版本註記:
http://www.cisco.com/en/US/docs/routers/access/cisco_router_and_security_device_manager/software/release/notes/SDMr232.html#wp35379

所有 SDM 版本註記清單:
http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_release_notes_list.html

2009年2月16日 星期一

利用 VTP 散佈 VLAN 資訊 (CNA-03-004)

CCNA Exploration 4.0 第三學期上課檔案 (CNA-03-004), 利用 VTP 散佈 VLAN 資訊, 聯合三台 Switch 啟用 VLAN 功能, 來分離兩個 Layer 2 的世界.




這個例子如同前一個例子一樣. 我們曾經遇到過一些困擾, 必須要手動一台一台在交換器上加入 VLAN 資訊. 所以這個例子, 我們改用 IOS 所提供的一個自動的方法: VTP (VLAN Trunking Protocol).

VTP 簡單的說, 是 Cisco 自己產品的專屬協定, 可以在 Cisco 交換器間, 自動散播可用的 VLAN 資訊.

這個練習我將 VLAN 號碼改了, 希望大家可以不用偷看 Core Switch的設定, 只要在Switch1 和 Switch2上啟用VTP, 就可以利用 VTP 自動的方式取得 Core Swtich 上的 兩個 VLAN 資訊.

Switch1 和 Switch2 先扮演 VTP Client 的腳色, 收聽 VTP Server (這個例子就是 Core Switch) 所放送出來的 VLAN 資訊.

Client  設定:

Switch1(config)#vtp mode client
Switch1(config)#vtp domain ccna
Switch1(config)#

Server 設定:

CoreSwitch(config)#vtp mode server
CoreSwitch(config)#vtp domain ccna
CoreSwitch(config)#

和 VLAN 設定一樣, 我們無法使用 show run 來看設定的內容, 只能使用 show vtp status.

Switch1:

Switch1#show vtp status
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Client
VTP Domain Name                 : ccna
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x9E 0x49 0xD8 0xC7 0xED 0x7C 0xB2 0x01 
Configuration last modified by 20.1.1.101 at 3-1-93 00:01:58
Switch1#

CoreSwitch:

CoreSwitch#show vtp status
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Server
VTP Domain Name                 : ccna
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x9E 0x49 0xD8 0xC7 0xED 0x7C 0xB2 0x01 
Configuration last modified by 20.1.1.101 at 3-1-93 00:01:58
Local updater ID is 20.1.1.101 on interface Vl1 (lowest numbered VLAN interface found)
CoreSwitch#

經典熱門文章