如果您喜歡這裡的內容,記得分享到您的Facebook和Twitter上面所有的朋友們吧!


2009年3月22日 星期日

利用具備一個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性 (CNA-03-007)

CCNA Exploration 4.0 第三學期上課檔案 (CNA-03-007), 利用具備一個 LAN 網路卡的路由器, 來提供三個 VLAN 間的連通性.




一個 LAN 埠如何提供三個 VLAN 的連通性? 這需要一點額外的設定. 簡單的說, 如果路由器看得懂 Switch 用來做記號的 VLAN 標籤, 那這部路由器, 就可以在上面也提供 "虛擬的" 網路卡 (Virtual Interface), 在各 VLAN 上, 同樣可以提供各 VLAN 間的連通性.

路由器要如何看得懂, 首先是硬體必須支援, 至少必需是 100Mbps. 不過只要是最近新買的路由器都沒有這個問題, 除非是早期的 Cisco 2600 時代的產品.

關於路由器的設定, 其實只要多宣告 "sub-interface" 即可":


interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.100
 encapsulation dot1Q 10
 ip address 172.17.10.1 255.255.255.0
!
interface FastEthernet0/0.200
 encapsulation dot1Q 20
 ip address 172.17.20.1 255.255.255.0
!
interface FastEthernet0/0.300
 encapsulation dot1Q 30
 ip address 172.17.30.1 255.255.255.0
!

其中, 10, 20, 30 分別是 VLAN 的號碼. 802.1Q 是標籤的格式. "Sub-interface" 的號碼, 倒是不需要和 VLAN 號碼一樣. 本例中我故意取不同的號碼.

至於 Switch 端, 接路由器的這個埠, 必須設定成主幹模式 (Trunk Mode), 這樣各 VLAN 的訊框, 才會被加上標籤送給路由器.


interface FastEthernet0/11
 switchport mode trunk
!

這樣的設定, Cisco 網站習慣稱呼它為 "Router-on-a-stick", 也就是一隻腳的路由器!

這種配置同時解決一個問題, 如果我們還必須連接更多 VLAN, 那麼還是只需要一個 LAN 埠即可! 否則, 每多一個 VLAN, 就要多一張網卡, 那就會有很多問題. 試著想想如要多加入 100個 VLAN 的狀況會是如何!
如果您喜歡這篇文章,不考慮試試Email訂閱嗎?


Related Posts with Thumbnails

2 則留言:

  1. 老師你好:
    請問一下有關
    至於 Switch 端, 接路由器的這個埠, 必須設定成主幹模式 (Trunk Mode), 這樣各 VLAN 的訊框, 才會被加上標籤送給路由器.
    interface FastEthernet0/1
    switchport mode trunk
    這是在S1設定嗎??? S1與Route 連接是f0/11
    怎麼會變成interface FastEthernet0/1???
    謝謝老師

    回覆刪除
    回覆
    1. 您是對的!Fa0/11 才對!我已經更正在內文裡面了!非常感謝您的指正!

      刪除

小技巧:也可以 匿名 留言!

經典熱門文章